Da Madcommerce.

Per accedere alla tabella negozi cliccare da menù Tabelle > Negozio > Negozi, dove verrà visualizzata l'elenco negozi.

Ricerca per filtri

La ricerca può essere effettuata per: Negozio, Città, Indirizzo. Compilare il campo/i campi dei filtri da applicare alla ricerca e poi premere Invio.
Cliccando sulla freccetta a lato di ogni filtro è possibile ordinare gli elementi della colonna per ordine alfabetico crescente o decrescente.
Per ogni negozio è possibile effettuare modifiche Modifica.jpg, impostarlo come online Online.png, impostarlo come offline Offline.png oppure eliminarlo Elimina.jpg. È possibile eliminare più negozi contemporaneamente spuntando i checkbox presenti sulle righe relative e cliccando successivamente il link Elimina selezionati nella barra in alto a destra, oppure si possono selezionare/deselezionare tutti i negozi per l'eliminazione tramite i link Seleziona tutti/Deseleziona tutti.


Finestra Tabelle > Negozio > Negozi

Inserimento Negozio

Per inserire un nuovo negozio cliccare sul pulsante Nuovo posto in alto a destra.
In questo modo si raggiunge la pagina di inserimento dati, la quale si sviluppa su tre tab, visibili in alto a sinistra: Negozio, Aperture e Media.
Una volta raggiunta la pagina di inserimento dati, apparirà una finestrella in corrispondenza della barra degli indirizzi che richiederà l'autorizzazione a localizzare la posizione corrente tramite il servizio di Google Maps.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio


Cliccando sul pulsante Comunica posizione verrà impostata automaticamente la Google Map presente all'interno della pagina con la posizione corrente e sarà possibile manipolarne i segnaposto Pin thumb.png. In caso contrario, la mappa verrà impostata successivamente cliccando sul pulsante Genera.


Negozio

Per creare il negozio è necessario compilare i campi Negozio, Magazzino, Latitudine e Longitudine presento nella tab Negozio. A questo punto è possibile salvare il negozio con gli appositi pulsanti Salva e Salva e Chiudi in basso a destra, oppure cliccare su una delle ulteriori tab (Aperture o Media): in questo modo i dati vengono salvati automaticamente e si passa all'inserimento dei successivi.
Una volta inseriti i campi obbligatori è possibile cambiare tab a piacimento, gestendo autonomamente il completamento dei dati.
Se viene cliccato il pulsante Indietro prima del salvataggio dei dati, le ultime modifiche andranno perse e si tornerà alla lista dei negozi.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio > Negozio


Impostazione Coordinate negozio

Tramite la Google Map presente all'interno della pagina è possibile impostare le coordinate corrispondenti alla posizione del negozio visualizzata all'interno del sito.
Per generare coordinate precise è necessario compilare tutti i campi di indirizzo (Indirizzo, Città, CAP, Provincia, Nazione). In ogni caso, per consentire la generazione è necessario compilare almeno i campi Indirizzo, Città e Nazione.
Una volta impostati i campi di indirizzo, cliccando sul pulsante Genera viene aggiornata automaticamente la posizione visibile nel riquadro della Google Map e vengono impostati automaticamente i campi Latitudine e Longitudine.
Nel caso in cui l'indirizzo correttamente inserito non venga trovato tramite questo meccanismo, oppure venga inserito un indirizzo non corretto, la Google Map si posizionerà su coordinate generiche.
Nel caso in cui l'indirizzo correttamente inserito non venga mostrato in maniera sufficientemente precisa all'interno della Google Map, o venga trovato un indirizzo adiacente al posto di quello desiderato, è possibile manipolare la mappa tramite i pulsanti di zoom +/- presenti nel riquadro e trascinarne il contenuto con il mouse fino a raggiungere la posizione desiderata.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio > Negozio


A quel punto, cliccando su tale posizione il segnaposto Pin thumb.png presente sulla mappa verrà spostato in corrispondenza di essa e le coordinate si aggiorneranno automaticamente.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio > Negozio


Aperture

Nella tab Aperture è possibile inserire gli orari di apertura del negozio che verranno visualizzati sul sito. È possibile inserire testi differenti per ogni lingua che si desidera gestire. I campi presenti consentono di inserire opzionalmente sia gli orari di apertura Standard che gli avvisi di aperture Straordinarie.
All'apertura della tab si trova un menu a fisarmonica aperto sulla lingua di default, in questo caso l'italiano.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio > Aperture


Cliccando sulle barre grigio chiaro con il nome della lingua si chiudono e/o si aprono le sezioni relative.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio > Aperture


In questo modo è possibile inserire i testi per ciascuna lingua di interesse.


Finestra Tabelle > Negozio > Negozi > Nuovo Negozio > Aperture


Modifica Negozio

Per modificare i dati di un negozio inserito precedentemente cliccare sull'icona di modifica Modifica.jpg nella riga corrispondente della tabella principale. Non sarà più necessario consentire l'accesso alla posizione corrente. A questo punto si procede come per l'inserimento, cambiando i dati di interesse e salvando con gli appositi pulsanti Salva e Salva e Chiudi in basso a destra. Il pulsante Indietro permette di tornare alla lista delle tariffe senza salvare le modifiche.


Finestra Tabelle > Negozio > Negozi > Modifica Negozio