Da Madcommerce.

Per accedere alla tabella delle lingue cliccare da menù Tabelle > Internazionalizzazione > Lingue, dove verrà visualizzato l'elenco di tutte le lingue in cui il sito può essere tradotto. Le lingue inserite in questa tabella determineranno l'impostazione di tutti i menu a fisarmonica utilizzati per l'inserimento dei testi all'interno del sito: potranno essere inseriti tanti testi differenti quante sono le lingue presenti in questa tabella.


Ricerca per filtri

La ricerca può essere effettuata per Codice, Nome, Collation (ovvero, il set di caratteri utilizzato). Compilare il campo/i campi dei filtri da applicare alla ricerca e poi premere Invio.
Cliccando sulla freccetta a lato del filtro è possibile ordinare gli elementi della colonna per ordine alfabetico crescente o decrescente.
Per ogni lingua è possibile effettuare modifiche Modifica.jpg oppure eliminarla Elimina.jpg. È possibile eliminare più lingue contemporaneamente spuntando i checkbox presenti sulle righe relative e cliccando successivamente il link Elimina selezionate nella barra in alto a destra, oppure si possono selezionare/deselezionare tutte le lingue per l'eliminazione tramite i link Seleziona tutte/Deseleziona tutte.

(È bene comunque non eliminare almeno la lingua italiana, in modo che il sito venga localizzato correttamente).


Finestra Tabelle > Internazionalizzazione > Lingue


Inserimento Lingua

Per inserire una nuova lingua cliccare sul pulsante Nuova posto in alto a destra. Comparirà come prima riga della tabella un form in cui sarà possibile inserire i dati della lingua.
È possibile salvare la nuova lingua premendo Invio o cliccando sul pulsante Conferma. Cliccando invece su Annulla il form scomparirà e i dati finora inseriti andranno persi.


Finestra Tabelle > Internazionalizzazione > Lingue


Modifica Lingua

Per modificare i dati di una lingua inserita precedentemente cliccare sull'icona di modifica Modifica.jpg nella riga corrispondente della tabella principale. Tale riga verrà sostituita da un form compilato con i dati della lingua. A questo punto si procede come per l'inserimento, cambiando i dati di interesse e salvando con il pulsante Conferma. Il pulsante Annulla consente di eliminare il form, tornando alla lista delle lingue senza salvare le modifiche.


Finestra Tabelle > Internazionalizzazione > Lingue